Taxi Driver Online

UK cab trade debate and advice
It is currently Thu Jun 30, 2022 11:03 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed May 18, 2022 8:56 pm 
Offline
User avatar

Joined: Tue Nov 09, 2021 7:42 pm
Posts: 6
Hello all,

I have a 2005 TX2 which has the 2.4 Ford engine and Auto box. The problem I am having is that often, it won't start in Park, I have to shift to Neutral. I understand this is likely to be the Inhibitor (neutral safety) Switch.

Can anyone tell me if this is a Ford part and where I might source one?

Thanks.


Top
 Profile  
 
PostPosted: Sat May 21, 2022 7:05 pm 
Offline
User avatar

Joined: Tue Feb 03, 2015 6:16 pm
Posts: 235
Location: glasgow
TX2man wrote:
Hello all,

I have a 2005 TX2 which has the 2.4 Ford engine and Auto box. The problem I am having is that often, it won't start in Park, I have to shift to Neutral. I understand this is likely to be the Inhibitor (neutral safety) Switch.

Can anyone tell me if this is a Ford part and where I might source one?

Thanks.

google is your friend
https://picclick.co.uk/Taxi-Lti-Tx1-Tx2 ... 45425.html

_________________
i started out with nothing and ive still got most of it left


Top
 Profile  
 
PostPosted: Sun May 22, 2022 10:37 am 
Offline
User avatar

Joined: Tue Nov 09, 2021 7:42 pm
Posts: 6
Thanks,

Of course I asked the Internet before coming here, I found that listing, which is sold, but it doesn't answer my question about whether or not it is a Ford part?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Group